SwordHealth Currently Unavailable

Incident Report for Sword Health

Resolved

The upstream provider has implemented a fix and the issue was fully mitigated
Posted Dec 05, 2025 - 09:15 UTC

Identified

The issue was caused by an upstream provider
Posted Dec 05, 2025 - 08:50 UTC

Investigating

We are currently investigating this issue.
Posted Dec 05, 2025 - 08:48 UTC
This incident affected: Enrollment Platform, Treatment Platform, Mobile API, Corporate Website, and AI System.